Talk About the Latest in Home Automation/Home Electronics
Home Automation Forum

Smarthome Forum
 
Home | Profile | Register | Active Topics | Search | FAQ | Smarthome
 All Forums
 General Discussion
 Thermostats & HVAC Control
 Thermostat Status -dashes-

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
Check here to subscribe to this topic.
   

T O P I C    R E V I E W
KeepOnTruckin Posted - 12/23/2011 : 07:48:17 AM
My 2nd day with a remotely controllable 2491T7E starts with the Status shown being the dashes, as discussed in another thread. Clicking Refresh does not pick it up.

Any thoughts? I note that my other 3 scenes in 2 room that I have been playing around with still seem to work.
30   L A T E S T    R E P L I E S    (Newest First)
KeepOnTruckin Posted - 04/07/2013 : 1:57:20 PM
What is after step 5?

I believe I have successfully assigned and set the port-forwarding in the router set-up, to match a port I set in the SL. I have, more than once, re-done steps 1-5 after closing out all browsers and power-cycling the SL. When REALLY stuck, I have 5-tapped it and followed steps 1-5, assigned port#, etc., form scratch.

Each time it "messes up", (assuming that is IS "messing up" and not reacting to invalid settings), it will go back to "working" as I would hope and expect after being power-cycled.

Does any of this indicate, in your opinion, a defect in the SL, or rather, improper settings?

Each time this thing calls for re-direction to the IP address which I do not recognize and which will not load, I note that the IP camera continues to operate, and continues to list the former SL IP address, which the router itself also continues to list as the IP address.

Anyway, I am now away from the SL for a week or two. If it stop working before I get back up there, I might try SH tech support.

Thanks.

KoT

stusviews Posted - 04/07/2013 : 12:41:06 PM
As I repeatedly indicated, there were a few more steps to go.
KeepOnTruckin Posted - 04/07/2013 : 05:41:24 AM
Oh, well--I guess I'm done too.

The next morning, "I'm not at home" gets redirected to an unrecognized IP address and port: 68.192.xxx.xxx:1904, to which it will not connect. If I click "I'm at home", it indicates that no SL is found on the network. The router clearly shows the SL is present.

When typing the IP address and assigned directly port into the address bar, it connects. But from a year's plus of experience, I expect it will not last.

Thanks for trying......
stusviews Posted - 04/06/2013 : 6:24:36 PM
quote:
Originally posted by KeepOnTruckin
DHCP is enabled.


I'm done.
KeepOnTruckin Posted - 04/06/2013 : 3:26:32 PM
I now have the SL set with a port # that I have, I believe, set to be forwarded, in the router, using HTTP service, to the SL IP address (192.168.1.4). DHCP is enabled. No authentication. "Seems" to be working, at least for now.

When I log in through "I'm not at home", it successfully and quickly redirects to the WAN IP address w/forwarded port, accessing the SL. The actual WAN IP address and port # show in the address bar. Not sure if it should, but there you have it.

We shall see......
stusviews Posted - 04/06/2013 : 12:16:28 PM
quote:
Originally posted by stusviews

quote:
Originally posted by stusviews

"I'm not at home," is a number of steps beyond step 5. Any changes such as including a port number, resetting the SL, changing from static to DHCP, etc. requires starting anew from step 1.


"I'm not at home," is a number of steps beyond step 5. When you can reliably connect by browsing to the selected static IP address (not using the smarthome.smartlinc service), you should assign a SL port and forward that port on the router. Then test access using the port.


"I'm not at home," is a number of steps beyond step 5. But, you keep trying nonetheless.
KeepOnTruckin Posted - 04/06/2013 : 06:05:04 AM
Note: with the camera unplugged, "I am not at home" successfully re-directs to the IP address, xxx.xxx.xxx.xxx:80, but does not connect, and times out.

What is next for me?
KeepOnTruckin Posted - 04/06/2013 : 05:56:22 AM
Now the SL is set as you suggest after Step 5, 3/30.

When I try to logon as "I am not at home", it successfuly redirects me to the IP address, xxx.xxx.xxx.xxx:80, asks for authenication, and nothing works. Eventually, it comes up with the screen that the IP camera shows when failing ITS logon, with the IP address in the address bar, without the port #, IE. xxx.xxx.xxx.xxx

As in the past, if I put the camera logon info in the authentication, it will log onto the camera.

I think I will unplug the camera and try.

KeepOnTruckin Posted - 04/06/2013 : 05:29:17 AM
I have always (except maybe during a brief period when I knew much less than now)b een able to connect when at home.

I have now 5-tapped. LAN is as it has been: 192.168.1.4:80

As you suggested at Step 3, 3/30, I have disabled DHCP.

After posting this post, I will close all browsers and power-cycle the SL.

KoT

stusviews Posted - 04/05/2013 : 7:23:23 PM
quote:
Originally posted by stusviews

"I'm not at home," is a number of steps beyond step 5. Any changes such as including a port number, resetting the SL, changing from static to DHCP, etc. requires starting anew from step 1.


"I'm not at home," is a number of steps beyond step 5. When you can reliably connect by browsing to the selected static IP address (not using the smarthome.smartlinc service), you should assign a SL port and forward that port on the router. Then test access using the port.
KeepOnTruckin Posted - 04/05/2013 : 7:02:30 PM
By the end of the week--I could no longer logon.

I am now at the SL for a couple of days.

Re-doing as per instructions above of 3/30, 12:16, I am back to what happened as I wrote on 3/30, 2:02. It will not let me into the SL while 'I am not at home". It successfully re-directs me to my IP address, then asks for a username and PW. It will not accept anything that gets me into the SL, but the username and PW for the camera will get me into the camera.

Suggestions appreciated for my little Saturday project.

Thanks.
stusviews Posted - 04/01/2013 : 7:11:59 PM
Yes, when everything is working correctly, you can select "I'm not at home," from your LAN and emulate accessing the SL as though you are really are not at home.
KeepOnTruckin Posted - 04/01/2013 : 7:05:28 PM
I will start again from scratch when I get back up there.

That said, I still do not understand why what I wrote in my 3/30/13, 2:02 posting happened, unless I re-plugged the SL in too quickly after unplugging it. Or maybe I missed something else/made another change after power-cycling.

Will doing "I am not at home" when I am actually on the LAN/at the SL give me an accurate indication of what will happen when I actually AM NOT at the SL?
stusviews Posted - 04/01/2013 : 5:50:43 PM
"I'm not at home," is a number of steps beyond step 5. Any changes such as including a port number, resetting the SL, changing from static to DHCP, etc. requires starting anew from step 1.
KeepOnTruckin Posted - 04/01/2013 : 5:12:20 PM
I had been power-cycling, and as noted in my 3/30, 2:02 pm posting, I was unable to log onto to the SL by choosing *I am not at home". The SL's log-on info would not allow me in, but putting in the camera's log-on info took me to the camera. (Maybe I should not have beeen able to log-on as "I am not at home" when I really was......???)

Unfortunately, I will not be back to the SL location for a week or more.

What I do not understand (besides most of it....) is how/where the updated IP address that the SL tries unsuccessfully to send me to comes from. The camera setting retains the original IP address that the SL stared out with (noted as *Router Global Address* in its settings and continues to successfully logs me into it. However, the camera setting has DHCP enabled. It has been over 2 years since the camera was set-up and it has worked pretty much without incident.

Alos, this only my second week with a router, previously only having the internet modem provided by TimeWarner/ISP.
stusviews Posted - 04/01/2013 : 2:59:53 PM
5. Power cycle the SL (unplug, replug) and browse to the new address
KeepOnTruckin Posted - 04/01/2013 : 2:50:18 PM
I'm not sure what you mean by *Step 5*. I assumed you meant Step 5 of your 3/30/13 12:16 post above. Rather, do you mean Step 5 of the SL Start Guide or Manual?
stusviews Posted - 04/01/2013 : 12:32:24 PM
Enabling DHCP causes the difficulty you experienced. Can repeatedly successfully access the SL at step 5? You'll need to exit the browser to test for repeated successes.
KeepOnTruckin Posted - 04/01/2013 : 04:59:12 AM
I had done step 5, above, and the results were as indicated at 2:02 PM.

I then re-enabled DHCP, re-setup the port-forwarding for port # 1234 in the router and at the SL. (At least I believe I did....(so far as I *understand* it...)) It worked properly, until this morning, when the SL then *successfully redirect[ed]* to an unknown IP address and port, which would then fail to connect. However, if I insert into the address bar the *old* IP address and port, (which is also the IP address of the camera) xxx.xxx.xx.xx:1234, it connects.

If I then delete/delete/delete/delete over the :1234, then type in *80*, it connects to the camera, although the *80* does not remain in the address bar. Then re-typing the *:1234* will again bring up the SL, although the *:1234* does remain showing in the address bar.

Will have to wait and see how long it works for, as we will not be back to ME for at least a week. (Have left the stat at a warmer temp, just in case, although it is warmer now anyway.

For all I know, the camera is making the SL work not-so-well..... Would be nice to have them both work well.
stusviews Posted - 03/30/2013 : 3:26:57 PM
What happens as step 5?
KeepOnTruckin Posted - 03/30/2013 : 2:02:57 PM
As you suggested above, I made the changes--disabled DHCP on the SL. I deleted the port-forwarding on router Port # 1234.

Now, While at a laptop on the LAN, when I go to the *find SL* page, and choose *I am not at Home*, I am asked for log-on and PW, which then sends me to the final log-on, which does not work for the SL log-on. But when I put in the username and PW for the camera, it logs onto the camera.....

What have I missed??? I presume the same thing would happen if I actually waa *not at home* and away from the LAN???
KeepOnTruckin Posted - 03/30/2013 : 1:48:45 PM
quote:
Originally posted by stusviews

A static IP for the SL is done by clicking on the wrench and selecting "Change Network Settings." More about that. later.

Your ISP provides a dynamic address, so the setting for the router, "Get Dynamically for ISP," is correct.

Q: How did you previously set the port number?

A: I picked the number out of thin air. Previously, I think it chose either 80 or 8080. I picked a different number because the camera uses 8080, and I thought there could be a conflict.

Q: The gateway, 192.168.1.1, is the address of your router. (Is 196 a typo?) The mask, 255.255.255.0, is standard for, most often, a PC LAN.

A: (196 was a typo)

If "I'm at home" indicates a dynamic IP, the the address can change.

Changing the IP and port requires several steps, as follows:
1. At the Change Network Setting screen, enter the desired port (e.g., 192.168.1.4).
2. Leave the Gateway at 192.168.1.1 and the Subnet Mask at 255.255.255.0 and the port at 80.
3. Select Disabled for the DHCP.
4. Select save.
5. Power cycle the SL (unplug, replug) and browse to the new address (e.g., http://192.168.1.4).

You can stop at that point and be assured that the SL address won't change. Or you can go on the the next phase an ensure that nothing else on your network uses that address.

Here's how another device can use the address: Most addresses on a LAN are assigned dynamically. That means that when a networked device is connected, it usually uses the first available address. If the SL cat5 cable is disconnected/defective or the SL has lost power, the new device may find and use that IP address. Although that situation is not highly likely, it is possible.

Q: BTW,, I have a concern about the differing ports you reported, to wit, 1234 and 80.

A: (again--I chose that number--I inserted it into the router port forwarding setting and into the SL setting.)

stusviews Posted - 03/30/2013 : 12:16:52 PM
A static IP for the SL is done by clicking on the wrench and selecting "Change Network Settings." More about that. later.

Your ISP provides a dynamic address, so the setting for the router, "Get Dynamically for ISP," is correct.

How did you previously set the port number?

The gateway, 192.168.1.1, is the address of your router. (Is 196 a typo?) The mask, 255.255.255.0, is standard for, most often, a PC LAN.

If "I'm at home" indicates a dynamic IP, the the address can change.

Changing the IP and port requires several steps, as follows:
1. At the Change Network Setting screen, enter the desired port (e.g., 192.168.1.4).
2. Leave the Gateway at 192.168.1.1 and the Subnet Mask at 255.255.255.0 and the port at 80.
3. Select Disabled for the DHCP.
4. Select save.
5. Power cycle the SL (unplug, replug) and browse to the new address (e.g., http://192.168.1.4).

You can stop at that point and be assured that the SL address won't change. Or you can go on the the next phase an ensure that nothing else on your network uses that address.

Here's how another device can use the address: Most addresses on a LAN are assigned dynamically. That means that when a networked device is connected, it usually uses the first available address. If the SL cat5 cable is disconnected/defective or the SL has lost power, the new device may find and use that IP address. Although that situation is not highly likely, it is possible.

BTW,, I have a concern about the differing ports you reported, to wit, 1234 and 80.
KeepOnTruckin Posted - 03/30/2013 : 11:26:02 AM
Where/how do I assign a static IP address to the SL? Do you mean at/with the router, or at/with the SL?

At the router--Under *Internet IP Address*: *Get Dynamically for ISP* is checked. Is this correct for my purposes? Also available is: *Use static IP Address* Would this be better?

I have no confidence in this. I re-set the network settings on the SL by doing the 5-tap thing.

Then I re-set through doing *find my SL, I am at home, and it showed and directed it to 192.168.1.4:1234 as the internal IP (1234 being a port # I previously set) It also showed the WAN IP address, the MAC adress and the SL ID #.

When I clicked into the SL, it shows the SL ID, the MAC address, the Port as *80*, Mask as *255.255.255.0*, DHCP as *enabled* Gateway as 192.196.1.1, and IP as 192.196.1.4.

Should any of this give rise to confidence that it will continue to operate?

There is a port forwarding/port triggering section in the router advance set-up section.

While it works now--the question is: will it continue to do so...

Any thoughts most appreciated
stusviews Posted - 03/29/2013 : 3:15:57 PM
My experience has been good. There is definitely a lag time, depending on the location I access it from. But I never not been able to connect.

Having some familiarity with IP addressing, I took several measures to ensure a connection. They are:
1. assign a static IP address to the SL (e.g., 192.168.0.234),
2. reserve that IP address on the router,
3. assign a port to the SL (e.g., 234), and
4. forward that port on the router.

Assigning a static address allows me to always find the SL locally. Reserving the address guarantees that another device will not use that address, even if the SL is disconnected. (Only a device that has that particular address can connect with that address). The port assignment is both for security and to make that device's identification unique. Forwarding that port on the router allows connection from a WAN (e.g., the internet).

You may want to make the changes when you're at the location of the router. In the event things get messed up, you won't be able to reset the router and start over without physical access to the router's reset button.
KeepOnTruckin Posted - 03/29/2013 : 2:05:39 PM
Generally, does the SL operate consistently if/when networked correctly?
stusviews Posted - 03/29/2013 : 11:38:25 AM
Yes, but you'll need a (often free) service such as those I mentioned earlier.
KeepOnTruckin Posted - 03/29/2013 : 10:12:41 AM
Is it possible to remotely log into the router at the beach place, thereby changing settings?
KeepOnTruckin Posted - 03/29/2013 : 05:48:26 AM
From WAN--from WIFI hotspots, from work, from home, etc--away from the SL. But it is/was always as slow as molasses, and from some places, particularly from work (a Fortune 100 company with heavy security on its internet and intranet), it would often *connect*--ask for and accept the logon info--but then *lose the connection*, and continuous attempts would usually fail. Yet the camera--on the same network, would have no such problems.

After a successful logon, the SL would often take from 5-10 seconds as the it *polled* each of the settings on the Venstar thermostat, slowly graying-out and updating each setting one by one after I had input a command. (That's 5-10 seconds for each single setting--At first I assumed it was not working--it took so long--but I learned that it was just slow, and that I had to wait.) To test if maybe the camera was slowing the network down, ie., writing to its cache and/or emailing info out in the event that the motion detector had been tripped, I would clear the cache and set the camera to *privacy mode*, which I though might effectively shut it down. But nothing has ever made the SL run any quicker.

(I am *studying* my network settings here at home to see what I can glean that might inform me as to what I should do for and at the SL. Here at home I have Verizon FIOS with a laptop, Kindle, 2 Panasonic TVs, a thermostat, a SlingBox, and a ROKU--all successfully connected via WIFI. All pretty much seamless.)

KoT
stusviews Posted - 03/29/2013 : 12:01:00 AM
quote:
Originally posted by KeepOnTruckin
[For awhile, I could put the IP address directly into the browser address bar and it would, connect, asking for the SL login. I believe I was NOT putting the port in. Which makes me wonder how it would know I was looking for the SL, as opposed to the camera.


LAN or WAN address? From home or at the vacation location?

On the road again

Smarthome Forum © 2000-2014 SmartLabs, Inc Go To Top Of Page
Powered By: Snitz Forums 2000 Version 3.4.07