Talk About the Latest in Home Automation/Home Electronics
Home Automation Forum

Smarthome Forum
Login or Register
 
Home | Profile | Register | Active Topics | Search | FAQ | Smarthome
 All Forums
 General Discussion
 Surveillance
 IP Camera cannot access via the internet
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

carlscheideer
New Member

USA
19 Posts

Posted - 05/03/2012 :  9:44:40 PM  Show Profile  Reply with Quote
Help. I got this nifty little camera at SmartHome - but I cannot get to it from the Internet. At least not here where I have set it up.

This is the $99 little gem #75790. Works slick right here - does everything I want. Even sees in the dark, listens in - very cool.

I have CenturyLink DSL, dynamic IP, in Wisc.
I set it up according to all of the instructions.
I got the internal IP address is fixed - so that works fine.
I even figured out how to get the Westell 327W11 modem / router to do port forwarding, and that looks ok, but that could be the problem.

I set up a domain name at dyndns.com - dyndns.org - and it is updating the IP address there. I found it even sends me an email when the IP address changes, so I could probably drop the account there.

I can access it just fine here using the local IP address.
When I try the internet IP address - it comes back not found.
Is it as simple as I need to literally get outside of this computer and local LAN before that works?

HELP. Thanks.

We're all in this together and I'm pulling for you.

mprimous
New Member

19 Posts

Posted - 05/09/2012 :  2:34:43 PM  Show Profile  Reply with Quote
Carl,

It sounds like everything you have done thus far has been correct.

If you are on a computer that is on the same network as the camera trying to use your dyndns address, your Internet Service Provider is probably not allowing that because it causes loopback.

Try accessing your camera from your smart phone while it is not on your local Wifi. Using your dyndns provided URL you should be able to login correctly.

Matt
Go to Top of Page

stusviews
Moderator

USA
11449 Posts

Posted - 05/09/2012 :  4:05:01 PM  Show Profile  Visit stusviews's Homepage  Reply with Quote
I'm able to access the camera that's on the same network as the computer I use to browse to my DynDNS account via either the local or DDNS service.

Do you add the port to your local address, for example 192.168.0.234:5678 where 192.168.0.243 is the static address and 5678 is the port?

If so, are you including the port with the DDNS service, for example, yourDynDNSaccount:port?

Stu's Views is Education and Fun. What do YOU want to VIEW today?
MathLandia High school mathematics learning fun.
Both Stu's Views and MathLandia are free websites that do not sell anything.
Saving energy is not always free. Be a world saver.
Go to Top of Page

carlscheideer
New Member

USA
19 Posts

Posted - 05/09/2012 :  7:00:11 PM  Show Profile  Reply with Quote
Well, I've tried a lot of things.

1. It may be that this router, or this DSL provider will not let me loop back and test it that way, from the same computer / router. It is CenturyLink in WI. The old CenturyTel. The Router is Westell 327W11. On that assumption, I am testing it externally, my son, or from home, etc.

2. BUT - I cannot access it remotely no matter what I do.

3. I set it up this way:
Camera IP Local: 192.168.1.51:8090
On the WWW: 174.124.70.76:8090 port forwarding to the local IP one.
I set up the DynDNS - and it gets updated there with no problem.
I can use the DynDNS URL name and port number, or the IP - same result. I used 8090 because that was in the example.
At first it came up at port 42 or 41 and I left it there - but I saw in the documentation that the Westell uses DHCP up to 46 - so thought I would move it up to 51.
I now see that some people think that the provider blocks 80, no matter what - 8080, 8090, etc.

When I try to sign in to the IP address and use a 2 or 3 digit port number, it takes a long time to respond, and then says the server stopped responding. Curious. When I use the 8090 I set up, it just says: Cannot find the server. So my theory is that there is something wrong with using any 80 number period.

4. My next attempt will be to assign it to port 51 on both sides. Avoiding the possible 80 blocking.

5. THEN - I plan to use the Single Static IP - which I read is analogous to IP passthru.
If you have any wisdom around that, I would appreciate it.

I am some distance from this place, so it will be a few weeks before I get back there.

At that time, I also plan to make the modem responsive to an external call - me - so I can change things from here - hopefully! Never tried that.

6. Lastly, I am going to pitch this Westell thing and get something else - assuming my DSL provider will support something else. I'm leasing the thing, so buying something else will ultimately save money. I don't know how tied they are to one piece of hardware or another. The same outfit, CenturyLink, here in St. Paul (QWest) lets you buy one from BestBuy!

Any wisdom at all on any of that would be appreciated.

It has been a fine education on NAT, Static NAT, ports, and whatnot. I also learned that the camera itself will send me a new IP address every time it is restarted, or powered down and up for any reason. If you don't mind typing the IP numbers, you don't need DynDns at all. There is an option to configure an email SMTP and it sends the IP every time.

Curious - I had also put in a gadget for Skype VOIP, and it configured itself and the router just fine - using port 47 - the one just above the DHCP stuff. They seem to know what they are doing!

I would highly recommend that SmartHome get something similar in place! Many thanks!


We're all in this together and I'm pulling for you.
Go to Top of Page

stusviews
Moderator

USA
11449 Posts

Posted - 05/09/2012 :  7:19:36 PM  Show Profile  Visit stusviews's Homepage  Reply with Quote
Can you access the camera from the local computer (same router) using 192.168.1.51:8090?

174.124.70.76 is provided by your IP provider and is subject to change.

List of port numbers you should not use.

Stu's Views is Education and Fun. What do YOU want to VIEW today?
MathLandia High school mathematics learning fun.
Both Stu's Views and MathLandia are free websites that do not sell anything.
Saving energy is not always free. Be a world saver.
Go to Top of Page

carlscheideer
New Member

USA
19 Posts

Posted - 05/09/2012 :  7:26:48 PM  Show Profile  Reply with Quote
YEP - local access works slick.

I know the other one will change if the whole business is powered down or whatever, but the camera sends the new IP every time.

Why do you ask?

We're all in this together and I'm pulling for you.
Go to Top of Page

carlscheideer
New Member

USA
19 Posts

Posted - 05/09/2012 :  7:34:38 PM  Show Profile  Reply with Quote
I see you would recommend that I use an UNUSED port number.
MY phone seems to be working just fine at 47.
How about 60, I see that is the lowest unassigned one above 46 - the DHCP range.

Thanks! Wish I knew more about this arcane business.

I see 8090 is one of the TO BE AVOIDED ports.
Phew - people do this for a living, right?

I only have a DUMB phone and an iPod - cheaper that way.
But, when I get back to this place I can go down the road a bit and use a neighbor's - all good ideas.

Thanks!

We're all in this together and I'm pulling for you.
Go to Top of Page

stusviews
Moderator

USA
11449 Posts

Posted - 05/09/2012 :  10:09:49 PM  Show Profile  Visit stusviews's Homepage  Reply with Quote
If you can access the camera locally (computer on the same network) using 192.168.1.51:port, then you should be able to access it using yourDynamicDNSname:port.

How did you open the port on the router?
quote:
Originally posted by carlscheideer

Thanks! Wish I knew more about this arcane business.


You will when everything is working.

Stu's Views is Education and Fun. What do YOU want to VIEW today?
MathLandia High school mathematics learning fun.
Both Stu's Views and MathLandia are free websites that do not sell anything.
Saving energy is not always free. Be a world saver.
Go to Top of Page

carlscheideer
New Member

USA
19 Posts

Posted - 05/10/2012 :  11:26:52 AM  Show Profile  Reply with Quote
Well, thanks for the encouragement!
To open the port on the Router, I downloaded the instruction book.
On p. 115, my edition, it explains about Custom Services.
I created a new service - *Camera
I forwarded 8090-8090, sent them to the Base Port of the camera - 51.
I did one for TCP and one for UCP - who knows what they mean!
Then I go to "enable" it and I select the camera which is sitting there in the dropdown list.
I THINK that is what I did.
Right now I am not sure if I put a '2' in that base port or a '51'.
Since the actual camera is connected in that drop down list.

What exactly is the 'base port' in that option?

Thanks! I appreciate you're taking the time to do this.
How can I repay?

We're all in this together and I'm pulling for you.
Go to Top of Page

carlscheideer
New Member

USA
19 Posts

Posted - 05/10/2012 :  11:30:16 AM  Show Profile  Reply with Quote
OK, looking at my notes, I think I put the base port at 8090.

I take it I should set that to something other than that!
I figured if in and out were identical, I could remember it better.

My plan now would be to put the BASE port to 2, and just use the drop down on the enable to point to the camera.

Use the range 60:60 - a port that is not on any list I can find.

Thanks again.

We're all in this together and I'm pulling for you.
Go to Top of Page

stusviews
Moderator

USA
11449 Posts

Posted - 05/10/2012 :  12:21:28 PM  Show Profile  Visit stusviews's Homepage  Reply with Quote
Step 1. Access to the camera locally first is a must. Did you assign a static IP address to the camera? Did you assign a port? Can you access the camera using that IP address plus port?

Step 2. After being able to reliably access the camera locally, you need to open the port on the router/modem and assign that same port to that particular IP address. I didn't see anything in the manual that showed that step.

Stu's Views is Education and Fun. What do YOU want to VIEW today?
MathLandia High school mathematics learning fun.
Both Stu's Views and MathLandia are free websites that do not sell anything.
Saving energy is not always free. Be a world saver.
Go to Top of Page

carlscheideer
New Member

USA
19 Posts

Posted - 05/10/2012 :  12:34:04 PM  Show Profile  Reply with Quote
OK - sorry. I didn't get the whole question.

1. I did used the menu on the camera to set up a static IP address.
51, I believe.

2. Locally, I can access the camera just fine. No problem.
Works slick, and I can change settings, etc.
I just can't get it to pass through the modem from outside.

3. I did the modem / router set up to send ports 8090:8090 to base port 2 - I think. Then set that new service (*camera) to the camera device. Which is indeed pointing at it's local IP address.

But, trying to connect to my IP address - and I do have the address - the camera sends me an update if it changes - I get two responses:

a - if I use port 8090 - it says server not found.
b - if I use a 2 digit port - any - it takes a long time, and then says the server stopped responding!

Thoughts? Thanks again. All of you!!

We're all in this together and I'm pulling for you.
Go to Top of Page

mprimous
New Member

19 Posts

Posted - 05/10/2012 :  1:02:03 PM  Show Profile  Reply with Quote
Carl,

The issue has to due with the Base Port you are choosing. You should be inputting "51" for your base port. Base Port is essentially the internal port of your camera that you have set. Locally, your camera is set to port 51 so that would be what you input as your base port for Port Forwarding in the router.

Try changing the base port from 2 to 51.

Matt
Go to Top of Page

carlscheideer
New Member

USA
19 Posts

Posted - 05/14/2012 :  2:26:26 PM  Show Profile  Reply with Quote
All right. I suspect you may have it Matt.
The base port is the same as the IP address - I can do that!
Point it to 51 which will be the static IP for the camera - just as soon as I can get to it to change it!!
Kind of "stupid" that the error was that easy! THANKS!
It will take me a week to do it as I am some distance away.
I assume it is possible to get into my modem the same way.
It has an option to allow remote access with a password.
Have to try that next time.

I'll check back and let you all know the outcome.

Greatly appreciate the help. I trust you folks are rewarded in some way!

Interface in this modem thing is NOT user friendly!

We're all in this together and I'm pulling for you.
Go to Top of Page

carlscheideer
New Member

USA
19 Posts

Posted - 06/01/2012 :  12:27:24 PM  Show Profile  Reply with Quote
Matt wins the prize. Thank you very much. Camera works slick.
Now I just need to figure out how to get IE to install the Active X so I can see the "other" controls. Next problem.

The key to this getting this to work with the Westell Modem / Router appears to be the following.


In the Camera Interface, set the IP address to 51.
(This may not be absolutely necessary, but I KNOW this works.)

Go to the Modem / router interface.
Select Service Configuration.
Click on Define Custom Service.
Call it something like *Camera.
(all custom services have * on the name)
Select port forwarding Ranges of Ports.
Set the port range to 51:51. Others may work, but 8090:8090 will NOT!
Set base host port to 51.
Set protocol to TCP.
I then did an ADD and did the identical thing with the protocol to UDP.
(Don't know if this is necessary, but it does work! I am a novice here folk.)
CLOSE this, and it will put you back at the service menu.
Select your new service name, *Camera, and ENABLE it.

THEN - select Single Static IP - and set it to the camera's IP address. That is IP passthru, apparently.

You CANNOT test it from the LAN to the external IP address - but this assemblage of function seems to work.

Thanks to all who contributed.


We're all in this together and I'm pulling for you.

Edited by - carlscheideer on 06/01/2012 12:30:29 PM
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Smarthome Forum © 2000-2014 SmartLabs, Inc Go To Top Of Page
Powered By: Snitz Forums 2000 Version 3.4.07