Talk About the Latest in Home Automation/Home Electronics
Home Automation Forum

Smarthome Forum
Login or Register
 
Home | Profile | Register | Active Topics | Search | FAQ | Smarthome
 All Forums
 General Discussion
 Surveillance
 Smartlinc url for Smarthome IP cam 75790 ?
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

vwmdaggie
Starting Member

7 Posts

Posted - 06/03/2012 :  8:58:16 PM  Show Profile  Reply with Quote
Can't seem to find a working solution for Windows 7/IE8 when trying to stream video from smarthome 75790 camera into the smartlinc user interface. These are the urls i've tried to enterinto the setup for SMartlinc, PLM Version: 92 Firmware Version: 3.0 Build Jul 15 2009

Tried http://IPaddress:port/ImageViewer?Mode
This works for a panasonic BL-C1 I have, but not the smartlhome 75790, I get a "webpage cannot be found" error box in the smartlinc camera window.

Tried http://IPaddress:port/videostream.cgi
This works on my ipad/safari but while windows IE 8 running on windows 7 64 bit prompts for username and password it then "blocks site from downloading files to my computer" as a status bar message. It gives me the option to download the cgi file but that is of course useless.. I don;t want to download it, I want it to display in the Smartlic interface AS ADVERTISED

Tried http://IPaddress:port/video.cgi but same result as videostream.cgi

Tried http://IPaddress:port/video.cgi?username=admin?pwd=mypassword but same result

Tried http://IPaddress:port
This gives me the login screen (ActiveX Mode or Server Push Mode)as it appears on the 75790 GUI but that is also useless

I read the entire manual for the http://www.smarthome.com/manuals/75790.pdf

but not helpful, really frustrated as Smarthome advertises that this camera "works" with Smartlinc but no info on what the url should say to make it happen in the product manual...

Tfitzpatri8
Administrator

USA
8604 Posts

Posted - 06/03/2012 :  9:06:51 PM  Show Profile  Reply with Quote
The SmartLinc doesn't display the content itself, it shows a frame and directs your browser to access and display the content itself. That means you need to set up port forwarding on the router and, if you don't have a static IP address from your ISP, a free dynamic DNS to make the camera content visible from outside your LAN.

Use http://[your ddns address]:[your forwarded port]/video.cgi to display video from the Smarthome camera. You can add the address to display as a frame in a SmartLinc room or you can navigate to the page directly. The first time you access it, and periodically afterwards, your browser will prompt for your login user name and password before displaying the feed.

If you access the unit via an Android or iOS device, use the Insteon app and you can save the login information in the Room setup screen and the app will manage login automatically.

Volunteer Moderator & Home Automation Enthusiast
Go to Top of Page

vwmdaggie
Starting Member

7 Posts

Posted - 06/03/2012 :  9:08:51 PM  Show Profile  Reply with Quote
btw http://192.168.0.126:86/snapshot.cgi will get me a snapshot using IE8/win7, but I want the video feed like by panasonic gives me, not a snapshot. Can IE8 not properly handle "video.cgi"?
Go to Top of Page

Tfitzpatri8
Administrator

USA
8604 Posts

Posted - 06/03/2012 :  9:17:13 PM  Show Profile  Reply with Quote
Maybe. I avoid IE like the plague. You may need to be content opening a dedicated IE window and logging into the camera directly, instead of using the frame in the SmartLinc display. On the bright side, going that route means you also have access to the pan & tilt and multiple camera features available through the ActiveX interface.

FWIW, video works fine for me using the video.cgi address with Chrome and Safari.

Volunteer Moderator & Home Automation Enthusiast
Go to Top of Page

vwmdaggie
Starting Member

7 Posts

Posted - 06/03/2012 :  9:29:19 PM  Show Profile  Reply with Quote
thx for reply but really not the issue; i have previously set up and can remotely log in to the smarthome 75790 though dyndns alias to my occasionally dynamic IP address:proper port number, etc, but this really seems to be either a camera issue or an IE8 issue: The SMartlinc video frame works fine in Safari using http://192.168.0.126:86/video.cgi or http://blahblah.dyn.net:86/video.cgi , but in IE8 64 bit on windows 7 will show me shapshots using http://192.168.0.126:86/snapshot.cgi but not video using http://192.168.0.126:86/video.cgi from the 75790 camera.

My other camera, Panasonic BL-C1, displays fine through smartinc frame using http://192.168.0.125:85/ImageViewer?Mode no matter what browser I use.
Go to Top of Page

vwmdaggie
Starting Member

7 Posts

Posted - 06/03/2012 :  9:36:06 PM  Show Profile  Reply with Quote
thx for your second reply, just bothered that process works for one camera and not the newer camera, seems like there should be an IE fix or setting. Also, can't get it to show under chrome as chrome just says "Not authorized" in video frame without prompts for useranem or password. Safari for windows seems to work though...

Is there some syntax guide for the 75790 url entry somewhere? Can't find this in user manual.
Go to Top of Page

Tfitzpatri8
Administrator

USA
8604 Posts

Posted - 06/03/2012 :  9:47:37 PM  Show Profile  Reply with Quote
I don't know. If you skipped the password or entered the wrong one, you may need to refresh the screen or log in via push mode to get past the unauthorized message. If you don't get the answers you need here on the user-to-user forum, be sure to follow up with Smarthome tech support.

Volunteer Moderator & Home Automation Enthusiast
Go to Top of Page

FWtxSH
Starting Member

USA
1 Posts

Posted - 06/23/2012 :  1:18:34 PM  Show Profile  Reply with Quote
I believe it is a security issue with Win7/IE8. I determined a way around the issue so it now works. Don't remember the specifics, but I believe you need to put the IP address of the Smarthome IP cam into IE as a "trusted" domain.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Smarthome Forum © 2000-2014 SmartLabs, Inc Go To Top Of Page
Powered By: Snitz Forums 2000 Version 3.4.07