Talk About the Latest in Home Automation/Home Electronics
Home Automation Forum

Smarthome Forum
Login or Register
 
Home | Profile | Register | Active Topics | Search | FAQ | Smarthome
 All Forums
 General Discussion
 INSTEON
 Lost Remote Connection (Update on Post # 19)
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

FloridaGary
Average Member

USA
123 Posts

Posted - 02/29/2012 :  9:25:57 PM  Show Profile  Reply with Quote
Hi All - I set up Port Forwarding and Address Reservation in my Netgear wireless router using the Smartlinc IP address (10.0.0.X:Port Number), opened the port number (4 digit number which is not being used by any other service) in my ATT Modem and all was working fine from a different network and over 3g with my Iphone. I noticed my ISP has changed my IP address (Dynamic) today. Now I cannot login remotely however I can still control my lighting on my LAN using my Iphone. I cannot access the "I'm at home" on my network using my laptop since my IP address changed.

What piece of the setup did I miss? My understanding is that I do not need to establish a static IP address from my ISP since Smartlinc acts as the server with a static address.

What am I missing?

Thanks,

Gary

Let there be light!

Edited by - FloridaGary on 03/08/2012 06:50:43 AM

stusviews
Moderator

USA
11463 Posts

Posted - 02/29/2012 :  9:52:20 PM  Show Profile  Visit stusviews's Homepage  Reply with Quote
Your laptop's browser may have cached the address. Try clearing the cache, shutting down, and restarting the browser.

Stu's Views is Education and Fun. What do YOU want to VIEW today?
MathLandia High school mathematics learning fun.
Both Stu's Views and MathLandia are free websites that do not sell anything.
Saving energy is not always free. Be a world saver.
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/01/2012 :  06:46:01 AM  Show Profile  Reply with Quote
quote:
Originally posted by stusviews

Your laptop's browser may have cached the address. Try clearing the cache, shutting down, and restarting the browser.



Thanks stusviews. That did the trick!

Gary

Let there be light!
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/01/2012 :  3:12:05 PM  Show Profile  Reply with Quote
quote:
Originally posted by stusviews

Your laptop's browser may have cached the address. Try clearing the cache, shutting down, and restarting the browser.



I may have spoken too soon. My ISP changed my Dynamic address yesterday, but this morning I was able to login which probably could have been done whether I deleted the cache or not this morning. I just returned home and my ISP changed my address again! Once again, I cannot access my smartlinc through its web based interface.

My ISP changing my dynamic address will be constant as most of you know, but it should not affect my ability to access my Smartlinc.

Any other recommended solutions?

Let there be light!
Go to Top of Page

Tfitzpatri8
Administrator

USA
8604 Posts

Posted - 03/01/2012 :  3:25:00 PM  Show Profile  Reply with Quote
The ISPs I've used don't normally change dynamic IP addresses very often unless something raises a red flag. Which port did you settle on for your SmartLinc? Are you running any other server software on port 80, or any filesharing app, pogoplug, NAS with a WAN connection, or anything else that would use a lot of upstream bandwidth? Are you running up-to-date antivirus and firewall software?

Volunteer Moderator & Home Automation Enthusiast
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/01/2012 :  4:23:57 PM  Show Profile  Reply with Quote
quote:
Originally posted by Tfitzpatri8

The ISPs I've used don't normally change dynamic IP addresses very often unless something raises a red flag. Which port did you settle on for your SmartLinc? Are you running any other server software on port 80, or any filesharing app, pogoplug, NAS with a WAN connection, or anything else that would use a lot of upstream bandwidth? Are you running up-to-date antivirus and firewall software?



I used port 6472. No other server software, filesharing, pogoplug or a WAN connection. Antivirus is always up to date and only using Vista's firewall, Netgear firewall and of course the Modem's firewall.

Gary

Let there be light!
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/01/2012 :  4:29:58 PM  Show Profile  Reply with Quote
quote:
Originally posted by FloridaGary

quote:
Originally posted by Tfitzpatri8

The ISPs I've used don't normally change dynamic IP addresses very often unless something raises a red flag. Which port did you settle on for your SmartLinc? Are you running any other server software on port 80, or any filesharing app, pogoplug, NAS with a WAN connection, or anything else that would use a lot of upstream bandwidth? Are you running up-to-date antivirus and firewall software?



I used port 6472. No other server software, filesharing, pogoplug or a WAN connection. Antivirus is always up to date and only using Vista's firewall, Netgear firewall and of course the Modem's firewall.

Gary



One other thing, my wife has to access her office through a VPN connection when connecting from home. Would that cause our ISP to change IP addresses more frequently?


Let there be light!
Go to Top of Page

Tfitzpatri8
Administrator

USA
8604 Posts

Posted - 03/01/2012 :  7:38:08 PM  Show Profile  Reply with Quote
I wouldn't expect a VPN to cause any issues. Are you having trouble with your modem, are one of you having to power-cycle it frequently?

Volunteer Moderator & Home Automation Enthusiast
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/01/2012 :  9:09:45 PM  Show Profile  Reply with Quote
quote:
Originally posted by Tfitzpatri8

I wouldn't expect a VPN to cause any issues. Are you having trouble with your modem, are one of you having to power-cycle it frequently?



No issues with our ATT modem or Netgear Router and never had to power-cycle either of them.

Let there be light!
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/01/2012 :  9:30:10 PM  Show Profile  Reply with Quote

One other note: my remote connection is redirecting to my previous IP address even after I clear the cache. This problem always corrects itself within 24 hours after my ISP changes my IP address. As noted earlier, I have deleted my cache, closed and re-opened the browser and still no luck. I thought my Smartlinc would send a static address no matter how often my ISP changes my external IP address. I set up port forwarding and address reservation to reflect the Smartlinc static and MAC address.

Gary

Let there be light!
Go to Top of Page

stusviews
Moderator

USA
11463 Posts

Posted - 03/01/2012 :  10:37:24 PM  Show Profile  Visit stusviews's Homepage  Reply with Quote
You are doing everything correctly.

I, too, find it unusual that your ISP changes the dynamic address so often.

But, that shouldn't prevent a dynamic name server such as smartlinc.smarthome.com from finding your PLM, especially that you're using a static address and dedicated port for the SmartLinc on your LAN, as you should.

A difficulty will be getting to a high enough level of support to get a reasonable response as to why the change occurs so often.

Stu's Views is Education and Fun. What do YOU want to VIEW today?
MathLandia High school mathematics learning fun.
Both Stu's Views and MathLandia are free websites that do not sell anything.
Saving energy is not always free. Be a world saver.
Go to Top of Page

EVIL Teken
Advanced Member

Canada
1243 Posts

Posted - 03/02/2012 :  08:21:14 AM  Show Profile  Reply with Quote
Hello Gary,

Would you be so kind and do the following for me. Please remove the MAC address of the SmartLinc from the router you have set up. I would like you to simply use the DHCP setting that are handed out by your router with no fixed MAC address in play.

You may have to power cycle both devices for the changes to take affect. Please ensure that the router is allowed to come back up, and stabilize and obtain the required network settings from your modem first. Give it about 3-4 minutes just in case. Once the router is up and running, please do power cycle the SmartLinc and verify that the network settings are reflective of the router addresses handed out.

Let me know if this results in any changes in network connectivity drop.

Teken . . .
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/02/2012 :  10:15:33 AM  Show Profile  Reply with Quote
quote:
Originally posted by EVIL Teken

Hello Gary,

Would you be so kind and do the following for me. Please remove the MAC address of the SmartLinc from the router you have set up. I would like you to simply use the DHCP setting that are handed out by your router with no fixed MAC address in play.

You may have to power cycle both devices for the changes to take affect. Please ensure that the router is allowed to come back up, and stabilize and obtain the required network settings from your modem first. Give it about 3-4 minutes just in case. Once the router is up and running, please do power cycle the SmartLinc and verify that the network settings are reflective of the router addresses handed out.

Let me know if this results in any changes in network connectivity drop.

Teken . . .



Hi Teken:

I removed the MAC address from my Netgear Wireless Router which I assume you mean to remove the Address Reservation. I power-cycled the Netgear Router, waited a couple of minutes and even re-booted my PC and Cached the browser. I then power-cycled the Smartlinc controller. I then access the Smartlinc "I'm at home" and noticed the Smartlinc internal IP has now changed. I assume that is because I removed the address reservation. All is working as it should, but the real test is when my ISP decides to change my IP address again.

Update: I am unable to access Smartlinc "I'm not at home". It appears I should re-establish the Address Reservation. Agreed?

Did I leave anything out or is there anything else you need to know from this test?

Thanks again,

Gary

Let there be light!

Edited by - FloridaGary on 03/02/2012 10:49:52 AM
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/02/2012 :  11:38:36 AM  Show Profile  Reply with Quote

Another Update:

I just realized that I did not update the Port Forwarding address to reflect the new Smartlinc internal IP address. Now that its updated to the correct address, I can access the Smartlinc through its web interface and I was also able to connect over 3G using my IPhone.

All is working as it should, but as stated previously, we have to wait until my ISP changes my IP address. Now the wait begins and I will update this thread when my IP changes.

Gary

Let there be light!
Go to Top of Page

EVIL Teken
Advanced Member

Canada
1243 Posts

Posted - 03/02/2012 :  12:53:27 PM  Show Profile  Reply with Quote
quote:
Originally posted by FloridaGary


Another Update:

I just realized that I did not update the Port Forwarding address to reflect the new Smartlinc internal IP address. Now that its updated to the correct address, I can access the Smartlinc through its web interface and I was also able to connect over 3G using my IPhone.

All is working as it should, but as stated previously, we have to wait until my ISP changes my IP address. Now the wait begins and I will update this thread when my IP changes.

Gary



Gary,

A couple things if you don't mind. Please reach out to your ISP and ask them if there is anything going on with respect to your account or if any system maintenance is under way.

Next, please confirm that when you say your IP address is changing that you mean the *Public IP* has changed correct?

Also, please do confirm for me that your *Router & Modem* is set to DHCP mode.

Also, just going off memory so please correct me if I am wrong. You have not made any other changes with in the router such as DMZ enabled, if so did you specify DMZ all IP's or just one IP?

Teken . . .
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/02/2012 :  1:16:01 PM  Show Profile  Reply with Quote
quote:
Originally posted by EVIL Teken

quote:
Originally posted by FloridaGary


Another Update:

I just realized that I did not update the Port Forwarding address to reflect the new Smartlinc internal IP address. Now that its updated to the correct address, I can access the Smartlinc through its web interface and I was also able to connect over 3G using my IPhone.

All is working as it should, but as stated previously, we have to wait until my ISP changes my IP address. Now the wait begins and I will update this thread when my IP changes.

Gary



Gary,

A couple things if you don't mind. Please reach out to your ISP and ask them if there is anything going on with respect to your account or if any system maintenance is under way.

Next, please confirm that when you say your IP address is changing that you mean the *Public IP* has changed correct?

Also, please do confirm for me that your *Router & Modem* is set to DHCP mode.

Also, just going off memory so please correct me if I am wrong. You have not made any other changes with in the router such as DMZ enabled, if so did you specify DMZ all IP's or just one IP?

Teken . . .



Teken:

I'll call my ISP and provide response in this forum.

When I refer to my IP address, yes I am referring to the Dynamic address that ATT is providing and changing periodically, or in my case very periodically

The only other change I noticed was after I removed the Address Reservation, the Smartlinc Internal IP changed. For example, it went from 10.0.0.6 to 10.0.0.XX and the port number I established stayed the same at 6472.

Router and Modem are both set to DHCP mode.

No other changes in router and no DMZ.

Gary

Let there be light!
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/02/2012 :  1:54:49 PM  Show Profile  Reply with Quote
quote:
Originally posted by FloridaGary

quote:
Originally posted by EVIL Teken

quote:
Originally posted by FloridaGary


Another Update:

I just realized that I did not update the Port Forwarding address to reflect the new Smartlinc internal IP address. Now that its updated to the correct address, I can access the Smartlinc through its web interface and I was also able to connect over 3G using my IPhone.

All is working as it should, but as stated previously, we have to wait until my ISP changes my IP address. Now the wait begins and I will update this thread when my IP changes.

Gary



Gary,

A couple things if you don't mind. Please reach out to your ISP and ask them if there is anything going on with respect to your account or if any system maintenance is under way.

Next, please confirm that when you say your IP address is changing that you mean the *Public IP* has changed correct?

Also, please do confirm for me that your *Router & Modem* is set to DHCP mode.

Also, just going off memory so please correct me if I am wrong. You have not made any other changes with in the router such as DMZ enabled, if so did you specify DMZ all IP's or just one IP?

Teken . . .



Teken:

I'll call my ISP and provide response in this forum.

When I refer to my IP address, yes I am referring to the Dynamic address that ATT is providing and changing periodically, or in my case very periodically

The only other change I noticed was after I removed the Address Reservation, the Smartlinc Internal IP changed. For example, it went from 10.0.0.6 to 10.0.0.XX and the port number I established stayed the same at 6472.

Router and Modem are both set to DHCP mode.

No other changes in router and no DMZ.

Gary




UPDATE: I spoke to my ISP (ATT) and they are seeing a power disruption 16 times over the past 30 days and confirmed it was happening in the mornings only. This detail removes me as the culprit who is causing the disconnects because I am at work on most of the dates they provided me. I will check back again in one week to find out if the disconnects are continuing and if so, I am replacing my DSL modem which is 10 years old. Boy time flies. I didn't realize how long I had it.

Gary

Let there be light!
Go to Top of Page

EVIL Teken
Advanced Member

Canada
1243 Posts

Posted - 03/02/2012 :  2:55:01 PM  Show Profile  Reply with Quote
quote:
Originally posted by FloridaGary

quote:
Originally posted by FloridaGary

quote:
Originally posted by EVIL Teken

quote:
Originally posted by FloridaGary


Another Update:

I just realized that I did not update the Port Forwarding address to reflect the new Smartlinc internal IP address. Now that its updated to the correct address, I can access the Smartlinc through its web interface and I was also able to connect over 3G using my IPhone.

All is working as it should, but as stated previously, we have to wait until my ISP changes my IP address. Now the wait begins and I will update this thread when my IP changes.

Gary



Gary,

A couple things if you don't mind. Please reach out to your ISP and ask them if there is anything going on with respect to your account or if any system maintenance is under way.

Next, please confirm that when you say your IP address is changing that you mean the *Public IP* has changed correct?

Also, please do confirm for me that your *Router & Modem* is set to DHCP mode.

Also, just going off memory so please correct me if I am wrong. You have not made any other changes with in the router such as DMZ enabled, if so did you specify DMZ all IP's or just one IP?

Teken . . .



Teken:

I'll call my ISP and provide response in this forum.

When I refer to my IP address, yes I am referring to the Dynamic address that ATT is providing and changing periodically, or in my case very periodically

The only other change I noticed was after I removed the Address Reservation, the Smartlinc Internal IP changed. For example, it went from 10.0.0.6 to 10.0.0.XX and the port number I established stayed the same at 6472.

Router and Modem are both set to DHCP mode.

No other changes in router and no DMZ.

Gary




UPDATE: I spoke to my ISP (ATT) and they are seeing a power disruption 16 times over the past 30 days and confirmed it was happening in the mornings only. This detail removes me as the culprit who is causing the disconnects because I am at work on most of the dates they provided me. I will check back again in one week to find out if the disconnects are continuing and if so, I am replacing my DSL modem which is 10 years old. Boy time flies. I didn't realize how long I had it.

Gary



Most excellent that you followed up with the ISP. They are the only ones that can tell you how many times you have power cycled or lost communications with them.

Lets assume for just a moment that the modem is fine. If you have a UPS back up supply. Please ensure you plug in both modem and router to this UPS back up.

There could be some bad power where you are and this is causing the device(s) to power cycle and thus causing you all this grief. To cover your basis I would ask you to submit a trouble ticket and have the modem replaced so at least this one area will be taken care of.

Thanks for the follow up and keep us updated.

Teken . . .
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/02/2012 :  7:22:47 PM  Show Profile  Reply with Quote

Thanks Teken. I also want to thank Stusviews and Tfitzpatri8. The 3 of you are incredibly helpful and provide good suggestions not only to me, but to all the other forum members. I know there are other contributors to this forum and of course that is appreciated, but I have noticed the 3 of you to be very active and giving of your time and assistance and I just wanted to say thank you.

Teken - I do not currently use a UPS, but thanks for the tip. Yes, I plan to get another modem and since none of my other electronics are showing power issues, I can only assume my 10 yr old modem needs replacing.

Gary

Let there be light!
Go to Top of Page

FloridaGary
Average Member

USA
123 Posts

Posted - 03/08/2012 :  07:03:36 AM  Show Profile  Reply with Quote
Hi All:

In the above posts, I was having an issue with losing access to my Smartlinc setup when my ISP (ATT) changed my Dynamic IP address. As noted, my ISP was changing my address quite frequently due to modem disconnects which may be related to the age of the modem (10 yrs.)My Netgear Wireless Router is only 3 yrs old and working fine. One of the recommendations early on in my Insteon setup was to setup an Address Reservation in my Router, but since removing the Address Reservation, it appears to have fixed my issue with losing the ability to connect remotely or accessing the Smartlinc web-based interface when my ISP changes my public IP address.

If any of you are experiencing this same issue, please take note and try this fix if you have set up an Address Reservation. By removing mine, it fixed the issue.

As a side note, I was having a minor issue with my Kitchen Cabinet lighting being the last remaining source of line noise. I added an in-line filter and all is working well.

As I have stated in other posts, I will not expand my system until I know all is working well and reliably. Now that it is, I have 2 appliancelincs on their way to control landscape lighting and I believe my final expansion will be the IP cameras. However before I purchase anything, I will be asking questions on this excellent user forum that has been a great help in my Insteon setup.

Thanks to all of you who have provided help in this forum.

Gary

Let there be light!

Edited by - FloridaGary on 03/08/2012 07:07:26 AM
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Smarthome Forum © 2000-2014 SmartLabs, Inc Go To Top Of Page
Powered By: Snitz Forums 2000 Version 3.4.07