Talk About the Latest in Home Automation/Home Electronics -
Home Automation Forum

Smarthome Forum
Insteon Home Automation
Login or Register
 
Home | Profile | Register | Active Topics | Search | FAQ | Smarthome | Security and Privacy | Do Not Sell My Info
 All Forums
 General Discussion
 Lighting and Appliance Control
 *SOLVED* Download and install ActiveHome Pro
 New Topic  Reply to Topic
 Printer Friendly
Next Page
Author Previous Topic Topic Next Topic
Page: of 3

Superdatsun
Starting Member

1 Posts

Posted - 09/10/2013 :  3:00:56 PM  Show Profile  Reply with Quote
I bought an X10 setup back in 2009, downloaded the ActiveHome Pro software on a spare laptop, and everything was good. I recently moved into a new place, and went to go reprogram my CM15A, but found out my laptop's hard drive had died. No problem, I thought, I'll just go download it again. But as I found out (as you all know), X10.com is not functional anymore, and everything is redirected to x10pro[ restricted ]. I tried emailing the x10pro[ restricted ] guys three times, but they never responded. I looked around the entire site, but couldn't find any download links. So what to do?

For grins, I tried http://x10pro[ restricted ]/software. Sure enough, they had a page hosted with downloads. The first entry on the download page was for ActiveHome Pro (setup_AHP.exe). Awesome! So I downloaded the file, and it turned out to be a basic installer (sw31a-AHP.exe) that tried to call home to a server for the files it needed. Since X10.com doesn't function anymore, the installation errors out with a generic "cannot connect to the server" error message (I can't remember the exact message, and I can't reproduce it now since I have the installation files). Okay, so what server is it looking for?

I fired up Wireshark and found that it was looking for software.x10.com:



Okay. Well, I wonder if x10pro[ restricted ] has a software server. Sure enough, there is a software.x10pro[ restricted ]. A quick ping (and still at the time of writing this) said the server had an IP of 63.211.210.21.



Now I knew the server exists, so I had to trick Windows into thinking the server at x10pro[ restricted ] is software.x10.com. To do this, you'll have to put a manual DNS entry into your Windows hosts file that directs all requests for software.x10.com to the server at software.x10pro[ restricted ].

Open Notepad as administrator (right click on the icon and select "Run as administrator"). From there, open "C:\Windows\System32\drivers\etc\hosts". Go to the bottom of that file and enter the line:
63.211.210.21	software.x10.com


It should look like this:



I saved the hosts file and closed it out, then retried the ActiveHome Pro installation. Sure enough, the server at software.x10pro[ restricted ] hosted the necessary files, and the installation worked perfectly.

I hope this helps folks out. I searched forever for a solution and was surprised that there wasn't one yet.

Now if only I can get my macros to turn on modules, and not just off.....

xytsrm
Starting Member

1 Posts

Posted - 09/10/2013 :  8:18:27 PM  Show Profile  Reply with Quote
Superdatsun,

Is there away to download the installation files from X10Pro, and then redirect the AHP installation to your own PC?

X
Go to Top of Page

Tuicemen
Average Member

Canada
74 Posts

Posted - 09/11/2013 :  04:59:08 AM  Show Profile  Visit Tuicemen's Homepage  Reply with Quote
Superdatsun good job
I'd played with WireShark before but had never thought of using it for this!
xytsrm
It may be possible to capture the info sent, certainly you can see what is sent.
This most likely take someone with more experience with WireShark then me.
Go to Top of Page

waynemor
Starting Member

Canada
6 Posts

Posted - 09/11/2013 :  11:32:35 AM  Show Profile  Reply with Quote
FYI, I just tried this. The download works fine BUT when you try to register you get an error.
You can close the registration box and continue. The AHP app does work for the basic stuff but currently there is no way to register either the basic app or any plugins.
I hope this helps,
Morry
Go to Top of Page

FazeShift
Starting Member

8 Posts

Posted - 09/14/2013 :  4:04:08 PM  Show Profile  Reply with Quote
Using Wireshark to capture an attempted registration, I found AHP attempts to resolve control.x10.com which no longer exists. In hopes that x10pro[ restricted ] was also hosting registrations, I added the following hosts entry:
63.211.210.21 control.x10.com

I then attempted another AHP registration, which still fails (404 not found) - it is apparent that x10pro[ restricted ] is not hosting this functionality at this time. But here is what I do know:
-AHP registration is done via HTTP, using a CGI script
-The requested URL also contains 3 pieces of data:
1. OrderID - This is the registration code I entered
2. ProductID - I assume this differentiates AHP and all the various plugins
3. SystemKey - This is likely some type of hash based on my OS, hardware, etc to differentiate one PC from another.
Here is an example URL - I altered the numbers for privacy, but the length/format as found:
http://control.x10.com/softwarereg.cgi?OrderID=123456789-AT123-1&ProductID=000F00012345678F&SystemKey=F000000000000000000000000000000000000000

What I conclude from this? It will take more than a static file on a web host to replace this. That fact that it is CGI leads me to believe that the registration isn't very advanced - likely the same method since late-90's/early-2000's, but it will be difficult to determine what AHP expects in the response to this request. It may be something simple, like an ok + the registrants name.
Go to Top of Page

gamefixer
Starting Member

USA
1 Posts

Posted - 09/24/2013 :  10:59:39 AM  Show Profile  Reply with Quote
Hey guys. Found this forum yesterday when I found out that I could no longer install/register my X10 AHP software and plugins. Really quite upsetting too... I've still got AHP running on a Win7-64 box but it crashes almost every day so I have the computer set to reboot at 03:00 hours every day. Doesnt always keep me out of hot water but its better then having to deal with it manually.

I was building another computer and installing XPSP3 on it so that I didn't have to deal with the constant crashes but we know how that went.... Guess I'm stuck on this Win7 box until someone gets the X10 registration servers back up.

Anyone know of an alternative either PC or MacOSX that can control X10 devices but also has a phone interface (iPhone and Android). I've been looking but only found one, Indigo 6 and I cant get it to control anything.

Go to Top of Page

n/a
deleted

5 Posts

Posted - 10/17/2013 :  5:11:56 PM  Show Profile  Reply with Quote
I have Every file of X10 Software ever put out if anyone can get them to work .. I also have a possible solution to some of you who just want Active home and Macros working .. Software called marmitek it doesn't use the Activation .. I have it running for a temp. solution for now , but working on getting all software working
I have a few friends that are good programmers , and they are helping me with this to see if we can get the activation out of the software and still run stable . I will update at a later time..

If it's Electronic, It can be Hacked..
Go to Top of Page

BLH
Advanced Member

6155 Posts

Posted - 10/18/2013 :  04:00:47 AM  Show Profile  Reply with Quote
The biggest problem. Most of the downloaded X10 software files where installers. Using the now defunct X10 servers for the full set of program files and registration. No X10 servers no new installs.

X10-Pro does have the installers on their web site but with no servers to get the full files and registration. Useless.
http://x10pro[ restricted ]/software/

Edited by - BLH on 10/18/2013 04:02:58 AM
Go to Top of Page

Geo
Advanced Member

Canada
815 Posts

Posted - 10/19/2013 :  12:36:21 PM  Show Profile  Reply with Quote
Unfortunately, this solution seems to no longer work. By modifying the HOST file the installation AHP software does go to the new server, but comes back with a message that the files cannot be found (there's no point getting upset about the wisdom of the company protecting the software which works with their hardware only. Just another drop in the bucket of bad decisions leading to their demise).
I found that you can download Marmitek AHP http://www.marmitek.com/en/product/09793 which installs without asking for registration. It is an European version, you can replace ICITIES.XML and HOLIDAY.XML from your original AHP installation to americanize it (I believe the two XML files can be found on the 'net, but I had my own. I also use my coordinates instead of the city name).
The European modules are different, so you will have to edit your AHX file by finding a suitable module. So far so good, I was able to get all my modules working.
It will probably not handle the daylight savings time change - if not, you'll have to do it manually. Just another reason to switch to Insteon.

GJN
Go to Top of Page

n/a
deleted

5 Posts

Posted - 10/20/2013 :  07:34:34 AM  Show Profile  Reply with Quote
(Geo) The Daytime / Night time lights work just fine. I have been using it for weeks now with all my lights. I would like to know if there is a solution for getting My Garage and other software to work with it .. I have 10 ActiveHome Modules that I have set up for Customers and Friends , and Now None of them can use any of it ..
I also have 10 Cameras setup in my house, they do not work now .. or I should say I can not view them with cell phone anymore

If it's Electronic, It can be Hacked..
Go to Top of Page

BLH
Advanced Member

6155 Posts

Posted - 10/20/2013 :  07:41:04 AM  Show Profile  Reply with Quote
Any of the AHP plug ins that went through the X10 servers. No longer work for now. I believe they are hard coded to the X10 defunct servers.
I still have a slim hope that the new X10Pro-USA company. Will eventually get the rights to the old X10 servers programs.
Go to Top of Page

javiert30
Starting Member

USA
1 Posts

Posted - 10/20/2013 :  1:38:33 PM  Show Profile  Reply with Quote
Same problem here, none of my AHP pluggins work, the best solution for me was install x10 commander on my iPhone from app store and install and configure the client on my computer to at least control my modules from my iPhone, once you install the client so you can have access to your modules from the internet you have to configure your router to forward port 6003 and use your external address on x10 commander on your iPhone, not the local ip address that you see in the client. To know your external ip address google "whats my ip"
Go to Top of Page

Geo
Advanced Member

Canada
815 Posts

Posted - 10/20/2013 :  1:43:22 PM  Show Profile  Reply with Quote
Overkill1, I know the sunrise and sunset functions work. I was concerned about the change over from the daylight savings to standatd time and vice versa. The function may not even be there in the European version as there are variety of different schemes among all the states involved. However, even if I have to adjust the time manually twice a year it is a small price to pay compared to reprogramming the entire system for a new controller and throwingt the perfectly good CM15 away.
The Marmitek software comes with the macros plug-in, I tried replacing or adding different modules but just the XMLs work.

GJN
Go to Top of Page

hwa
Starting Member

5 Posts

Posted - 12/03/2013 :  06:37:23 AM  Show Profile  Reply with Quote
Any chance I can get my hands on those files?

quote:
Originally posted by Overkill1

I have Every file of X10 Software ever put out if anyone can get them to work .. I also have a possible solution to some of you who just want Active home and Macros working .. Software called marmitek it doesn't use the Activation .. I have it running for a temp. solution for now , but working on getting all software working
I have a few friends that are good programmers , and they are helping me with this to see if we can get the activation out of the software and still run stable . I will update at a later time..

Go to Top of Page

Geo
Advanced Member

Canada
815 Posts

Posted - 12/03/2013 :  07:03:46 AM  Show Profile  Reply with Quote
Just Google it.

GJN
Go to Top of Page

Geo
Advanced Member

Canada
815 Posts

Posted - 12/03/2013 :  07:13:20 AM  Show Profile  Reply with Quote
I gave the link previously, but here is the zip file of the controller and the two location files.
https://dl.dropboxusercontent.com/u/10392169/Marmitek.zip

GJN
Go to Top of Page

hwa
Starting Member

5 Posts

Posted - 12/03/2013 :  08:34:56 AM  Show Profile  Reply with Quote
Hi Geo,

I'm actually after the original X10 files, the ones that the setup tries to download. If I read Overkill1's post correctly he seems to have those.

quote:
Originally posted by Geo

I gave the link previously, but here is the zip file of the controller and the two location files.
https://dl.dropboxusercontent.com/u/10392169/Marmitek.zip

Go to Top of Page

BLH
Advanced Member

6155 Posts

Posted - 12/03/2013 :  09:31:27 AM  Show Profile  Reply with Quote
I have seen reports that that new X10Pr0-USA is in the process of getting the files onto their servers.
Problem is the loader files are hard coded to go to the old X10 WTI servers and the programs themselves are also hard coded for the old X10 WTI servers.
Go to Top of Page

hwa
Starting Member

5 Posts

Posted - 12/03/2013 :  09:38:34 AM  Show Profile  Reply with Quote
I can work around the hard-coded name issues. Not having the actual files is the biggest problem. But let's hope they re-appear again. They're hosting the setup files, which is kinda curious since they're totally useless without the rest.

quote:
Originally posted by BLH

I have seen reports that that new X10Pr0-USA is in the process of getting the files onto their servers.
Problem is the loader files are hard coded to go to the old X10 WTI servers and the programs themselves are also hard coded for the old X10 WTI servers.


Go to Top of Page

BLH
Advanced Member

6155 Posts

Posted - 12/03/2013 :  1:06:06 PM  Show Profile  Reply with Quote
I don't know how they are handling it.
I know if you buy a CM15A from X10Pro-USA. They email you a link to a secure software download site to get AHP.
There are others trying to find the registration code site links. In their installed AHP files.
Go to Top of Page

n/a
deleted

5 Posts

Posted - 12/03/2013 :  3:47:22 PM  Show Profile  Reply with Quote
I will try and get something posted when I get home tonight, Check back after 9:00pm

If it's Electronic, It can be Hacked..
Go to Top of Page

Geo
Advanced Member

Canada
815 Posts

Posted - 12/04/2013 :  07:27:36 AM  Show Profile  Reply with Quote
I considered disassembling the code to see how to circumvent that silly copy protection, but then I found Marmitek and considered any hacking a waste of time.

GJN
Go to Top of Page

hwa
Starting Member

5 Posts

Posted - 12/05/2013 :  05:42:55 AM  Show Profile  Reply with Quote
I tried Marmitek, but I can't find a module that will operate the TM751. Haven't tried some of my other stuff because it doesn't do me any good without the TM751. Of lesser concern is that it's also an older version.

quote:
Originally posted by Geo

I considered disassembling the code to see how to circumvent that silly copy protection, but then I found Marmitek and considered any hacking a waste of time.

Go to Top of Page

hwa
Starting Member

5 Posts

Posted - 12/05/2013 :  05:46:01 AM  Show Profile  Reply with Quote
Thanks Overkill1! I appreciate your help.

Anyone else: do you have the files that the sw31a-AHP.exe (setup_ahp.exe) downloads? They're named setup_ahp_318.000, setup_ahp_318.001 etc. I used to have them until I lost them and of course subsequently X10 keeled over.

quote:
Originally posted by Overkill1

I will try and get something posted when I get home tonight, Check back after 9:00pm


Edited by - hwa on 12/05/2013 05:46:47 AM
Go to Top of Page

BLH
Advanced Member

6155 Posts

Posted - 12/07/2013 :  4:24:38 PM  Show Profile  Reply with Quote
The new owner of the X10 name. Has posted they are in the process of getting the registration and software servers back in operation.

Also the X10 forums are again working and in my case Users Name and Password still worked.
Go to Top of Page

n/a
deleted

5 Posts

Posted - 12/27/2013 :  06:53:58 AM  Show Profile  Reply with Quote
Has anyone tried HomeSeer?? I found this software and it seems to work with x10 products, but not sure how to set up anything in it ..
I have been playing around with it for a couple of days now and I still don't have it working correctly..

If it's Electronic, It can be Hacked..
Go to Top of Page

Tfitzpatri8
Administrator

USA
10827 Posts

Posted - 12/28/2013 :  09:07:51 AM  Show Profile  Reply with Quote
Check out the publisher's support forum: http://board.homeseer.com
Go to Top of Page

ekummel
Starting Member

2 Posts

Posted - 01/01/2014 :  8:45:14 PM  Show Profile  Reply with Quote
Just to keep this thread active for 2014, I'm replying to it to ask if anyone has any further information on this issue? I just attempted to download the software and it did not work. It gave me the server is not available message.
Go to Top of Page

Dave D
Starting Member

1 Posts

Posted - 01/11/2014 :  09:26:26 AM  Show Profile  Reply with Quote
Lost my AHP software due to an XP Pro crash on January 6. Google searches brought me to this site.

I tried the Superdatsun solution of modifying the C:\windows\system32\drivers\etc\hosts but it did not work. Possibly because the server IP Address has changed since his original posting in September, 2013.

I followed the bouncing ball to the Marmitek discussion from December 2013. While there are differences between the USA setup and the European one, I was able to complete setup and gain access to my CM15A. Having previously restored my AHP files from a backup hardfile, my primary *.ahx configuration came online instantly.

The resultant executable required me to:

1. Turn off any and all timers or macros that used dusk/dawn settings and replace them with newer events with the times manually entered.

2. Edit each wall switch, appliance or other module to again see the familiar screen icons we all know and love.

3. Am awaiting resurrection of the USA servers but in the interim, I can limp along with the modified configuration I successfully tested last night.

My thanks to all of you for your thoughtful and useful posts in this thread. I thought, as many as you did, that following the destruction of my Win XP registry I was out of the X10 game forever. Not so. I am up and running with a few manual workarounds as of Jan 11, 2014.

Dave
Go to Top of Page

[email protected]
Starting Member

USA
1 Posts

Posted - 01/13/2014 :  03:13:11 AM  Show Profile  Reply with Quote
Has anyone had any luck modifying the European version to add the US icons and devices. I can get it working and read my saved files. I have added the Icities and holiday file by changing there name to "_eu" but looking to see if anyone had any luck changing the device list.

Matt K.
Go to Top of Page

BLH
Advanced Member

6155 Posts

Posted - 01/13/2014 :  03:21:11 AM  Show Profile  Reply with Quote
There are some threads on the Tuicemens Forums on using the European AHP.
You may find some tips there.
http://tuicemen.com/forum/index.php?board=67.0
Go to Top of Page
Page: of 3 Previous Topic Topic Next Topic  
Next Page
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Smarthome Forum © 2000-2020 Smartlabs, Inc Go To Top Of Page
Powered By: Snitz Forums 2000 Version 3.4.07